Управление пользователями базы данных
Модератор: Разработчики расширений
- admin
- Разработчик
- Сообщения: 8013
- Зарегистрирован: 14 мар 2016, 11:32
- Откуда: Ленинградская
- Благодарил (а): 290 раз
- Поблагодарили: 1890 раз
Управление пользователями базы данных
Управление пользователями базы данных. Любая форма может стать хранилищем логинов и паролей к вашей базе данных. Данное расширение упрощает работу с большим количеством пользователей. Есть действия для массового создания и удаления пользователей из БД, а также функция генерации паролей. Более подробную информацию вы можете найти в настройках действия.
- Вложения
-
- UserMan 1.3.1.zip
- (4.86 КБ) 136 скачиваний
-
- UserManWeb 1.3.1.zip
- (3.59 КБ) 95 скачиваний
-
- USERMANDEMO.zip
- (63.25 КБ) 133 скачивания
- cordek
- Эксперт
- Сообщения: 2548
- Зарегистрирован: 14 май 2017, 14:53
- Благодарил (а): 737 раз
- Поблагодарили: 605 раз
- Контактная информация:
Управление пользователями базы данных
А я так и не донес до своей базы.
балуюсь разработкой LIMS JDX
cordek {/а} yandex/ru
cordek {/а} yandex/ru
- cordek
- Эксперт
- Сообщения: 2548
- Зарегистрирован: 14 май 2017, 14:53
- Благодарил (а): 737 раз
- Поблагодарили: 605 раз
- Контактная информация:
Управление пользователями базы данных
Мне не нравится, что пароли в двух местах хранятся. Смущает этот момент сильно.
балуюсь разработкой LIMS JDX
cordek {/а} yandex/ru
cordek {/а} yandex/ru
-
ControlFrik
- Заглянувший
- Сообщения: 2
- Зарегистрирован: 17 янв 2025, 18:56
- Благодарил (а): 1 раз
Управление пользователями базы данных
Я так понял, это то о чем давно просили, отделить админа от разработчика? Только в виде расширения.
-
ControlFrik
- Заглянувший
- Сообщения: 2
- Зарегистрирован: 17 янв 2025, 18:56
- Благодарил (а): 1 раз
Управление пользователями базы данных
Классное расширение!
Глубоко еще в скрипты и структуру не нырял, только присматриваюсь, поэтому сам причины не найду. Не знаю, наверно баг, но в справке к расширению сказано, что нельзя создать пользователя с правами разработчика.
На примере USERMANDEMO.FDB
1. Логинимся админом, создаем пользователя "user" и указываем логин, но забываем указать роль, получаем закономерно ошибку т.к. не указана роль.
2. Управление пользователями открывается и нового пользователя там нет, значит метаданные базы данных не менялись.
3. Если снова зайти в пользователя "user", убрать логин и нажать ОК, то при попытке зайти в управление пользователями вылезает окно что Изменение проекта запрещено, значит изменения в метаданные базы данных были внесены.
4. После перезапуска базы в окне авторизации в поле логина пустая запись, а в пользователях - пользователь без логина с правами разработчика, зайти им конечно не получится, но уж больно просто генерится эта ошибка.
p.s. Нагенерить таким образом таких записей можно сколько угодно
Глубоко еще в скрипты и структуру не нырял, только присматриваюсь, поэтому сам причины не найду. Не знаю, наверно баг, но в справке к расширению сказано, что нельзя создать пользователя с правами разработчика.
На примере USERMANDEMO.FDB
1. Логинимся админом, создаем пользователя "user" и указываем логин, но забываем указать роль, получаем закономерно ошибку т.к. не указана роль.
2. Управление пользователями открывается и нового пользователя там нет, значит метаданные базы данных не менялись.
3. Если снова зайти в пользователя "user", убрать логин и нажать ОК, то при попытке зайти в управление пользователями вылезает окно что Изменение проекта запрещено, значит изменения в метаданные базы данных были внесены.
4. После перезапуска базы в окне авторизации в поле логина пустая запись, а в пользователях - пользователь без логина с правами разработчика, зайти им конечно не получится, но уж больно просто генерится эта ошибка.
p.s. Нагенерить таким образом таких записей можно сколько угодно
- Вложения
-
- 001.jpg (130.75 КБ) 1158 просмотров
-
- 002.jpg (122.78 КБ) 1158 просмотров
-
- 003.jpg (136.65 КБ) 1158 просмотров
-
- 004.jpg (138.39 КБ) 1158 просмотров
-
- 005.jpg (56.36 КБ) 1158 просмотров
-
- 006.jpg (136.78 КБ) 1158 просмотров
- Runenkov
- Опытный
- Сообщения: 344
- Зарегистрирован: 21 сен 2016, 21:15
- Откуда: Ашхабад
- Благодарил (а): 124 раза
- Поблагодарили: 140 раз
Управление пользователями базы данных
admin писал(а):Исправил.
При замене расширений в примере дает ошибку